Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: engine problems


Rookie

Status: Offline
Posts: 1
Date:
engine problems


i have a 89 560sel that has a new ecm new fuel pump tune-up and most done by a dealer. but i still have a problem with rough idel and black smoke and horrible fuel milage. my economy gauge will sometime stay all the way in the red even at idel!! anybody have any ideas what i can try?

__________________


CERTIFIED POST WHORE

Status: Offline
Posts: 14069
Date:

This sounds like a classic vac. leak. There are many places an engine can loose vac.. With your economy gauge in the red while at an idle there is most defiantly a problem there. A vac. leak will also throw off the sensors because they rely on it to adjust fuel, spark and air.

 Some of the most common vac. leaks that I have seen with both the 420 and 560s are

 (1)     Leak at the brake booster vac. hose
(2)     Improperly routed - damaged or loose vac. hoses at the Throttle Body, Back of the instrument cluster or at the charcoal canister on inside drivers fender.
(3)     Leak under the air meter housing from the rubber plenum.
(4)     Leak at any or all of the eight rubber o-rings between the upper and lower intake
(5)     Leak at the intake manifold gasket itself
(6)     Improper timing (Worst case scenario) Jumped timing chain

 These are just a few of the most common places that I see many Mercedes start leaking. Best to have a mechanic inspect these areas to find out why. You could change every sensor on this vehicle and still have problems if there is a vac. leak. With your economy gauge in the red at an idle its a sure tip off there is vac. loss.

 I will post some photos of the above mentioned areas soon. You should also check out our W126 section of the forum. Just scroll down at the main page and you will see it. There is lots of real good information in there too.

One thing about a Mercedes-Benz V8 that you should know is that they will still run with an almost insane sized vac leak. This is due to the mechanical and electrical fuel injection system picking up when the other falls out of range.



-- Edited by SELLC at 18:59, 2007-06-06

__________________

A middle-aged loner on a crusade to champion the cause of the innocent, the helpless, the powerless - in a world of criminals who operate above the law.

LET'S GO BRANDON!

 



$y$Op

Status: Offline
Posts: 329
Date:

ctc1952 wrote:

i have a 89 560sel that has a new ecm new fuel pump tune-up and most done by a dealer. but i still have a problem with rough idel and black smoke and horrible fuel milage. my economy gauge will sometime stay all the way in the red even at idel!! anybody have any ideas what i can try?




You should go to the private forum
http://www.sellc.us/remote
There you can view photos of ALL of the parts that were spoken of in the responce above.
E-mail us for the password.


__________________

All the best!



User

Status: Offline
Posts: 476
Date:

Did you ever find out the problem with your car? Is it still acting up? Have you taken it in for service anywhere? If so what did they say?

Really like to help, just need more information.



__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.



Create your own FREE Forum
Report Abuse
Powered by ActiveBoard